استفاده بسیاری از وب سایت های آپاچی از نسخه های قدیمی و آسیب پذیر

به گزارش اِی وی نیوز، با توجه به تحقیقات موسسه Netcraft، تعداد بسیار کمی از سرورهای آپاچی از نسخه کاملا اصلاح شده آن استفاده می کنند. بسیاری از سایت های محبوب و معروف بر روی نسخه قدیمی، آسیب پذیر و اصلاح نشده از آپاچی میزبانی می شوند.

آخرین نسخه منتشر شده از Apache Stable نسخه ۲٫۴٫۷ می باشد که در ۲۵ نوامبر سال ۲۰۱۳ منتشر شد. تعداد بسیار کمی از سایت ها از این نسخه استفاده می کنند. بنا به گزارشات ارسالی کمتر از یک درصد از سایت ها در حال استفاده از نسخه های ۲٫۴ می باشند در صورتی که شرکت آپاچی به کاربران توصیه اکید کرده است که از نسخه های ۲٫۴ استفاده نمایند. برخی از سروهای آپاچی از نسخه های مربوط به ۲٫۲ آپاچی استفاده می کنند و آخرین به روز رسانی این نسخه مربوط به ۱۸ نوامبر سال ۲۰۱۳ نسخه ۲٫۲٫۲۶ می باشد. حتی بسیاری از سایت های محبوب و معروف در حال حاضر از نسخه های سری ۱٫۳٫x آپاچی استفاده می کنند و بسیاری از آن ها در حال اجرای نسخه ۱٫۳٫۴۲ می باشند.

با توجه به یافته های Netcraft، بیش از نیمی از وب سایت های آپاچی نسخه خود را مخفی نگه می دارند اگر چه با برخی راهکارها می توان نسخه آن را بدست آورد. برخی از سرورها با نسخه آسیب پذیر ممکن است نسبت به رخنه های موجود درآن نسخه آسیب پذیر نباشند.

می توان گفت که نسخه های ۲٫۲٫x غالب می باشند و هم چنان توسط بسیاری از برنامه ها مانند Red Hat مورد استفاده قرار می گیرند. و هم چنین بسیاری از سایت هایی که امنیت یک نگرانی اساسی برای آن ها به شمار می رود مانند OpenSSL از نسخه های قدیمی آپاچی استفاده می کنند. OpenSSL.org از نسخه ۲٫۲٫۲۲ آپاچی بر روی Ubuntu Linux استفاده می کند.

منبع: مرکز ماهر

About The Author

Related posts

Leave a Reply

نشانی ایمیل شما منتشر نخواهد شد. بخش‌های موردنیاز علامت‌گذاری شده‌اند *

*